Preview images not loading for some users
Incident Report for Iconfinder
Resolved
Everything is back to normal
Posted 27 days ago. Aug 25, 2017 - 10:24 CEST
Monitoring
Outage in one of our storage nodes caused rebalancing.
Posted 27 days ago. Aug 25, 2017 - 09:57 CEST
Investigating
We are currently investigating this issue.
Posted 27 days ago. Aug 25, 2017 - 09:42 CEST