Our service had a degraded performance due to overloaded search servers. All should be fine now,
Incident Report for Iconfinder
Resolved
Everything should be working normally.
Posted 2 months ago. Jun 08, 2018 - 10:51 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jun 08, 2018 - 09:51 CEST
This incident affected: Website and API.