General outage
Incident Report for Iconfinder
Resolved
We are back up. It was a temporary issue. We'll investigate further.
Posted Jun 22, 2022 - 11:40 CEST
Investigating
We are investigating the current outage. Recently our hosting provider, Cloudflare, has had downtime causing widespread outages across many web services.
Posted Jun 22, 2022 - 11:40 CEST
This incident affected: Website, API, and Server Infrastructure.