Issue caused by failing caching for web servers
Incident Report for Iconfinder
Resolved
The server issues have been resolved. Please contact support@iconfinder.com if you experience issues. Thank you for your patience.
Posted about 1 month ago. Sep 18, 2019 - 01:41 CEST
Monitoring
We have identified a serverside issue that causes the site and API to be slow or inaccessible. We are working on a fix. Thank you for your patience.
Posted about 1 month ago. Sep 17, 2019 - 23:30 CEST
This incident affected: Website, API, and Server Infrastructure.