Partial outage
Incident Report for Iconfinder
Resolved
This incident has been resolved.
Posted 6 months ago. May 19, 2017 - 16:07 CEST
Monitoring
Everything is back to normal. We are monitoring the service.
Posted 6 months ago. May 19, 2017 - 14:50 CEST
Investigating
We are currently investigating this issue.
Posted 6 months ago. May 19, 2017 - 14:19 CEST